Icare software

The component of Icare that talks to the USI Web Services requires .NET Framework 4 or 4.5 installed on your computer.

This is already installed on Windows 10 but may need to be installed on older PCs.

If you are only installing on a single PC then use:

If you are installing on a couple of PCs the use: